Infrastructure Maintenance Update
Resolved
May 11, 2026 at 10:30pm UTC
Maintenance ended
Affected services
Created
May 11, 2026 at 8:30pm UTC
Infrastructure Maintenance Update
Tonight between 2:00 AM – 4:00 AM IST, we’ll be working on major backend infrastructure improvements for Playzor.
There will be no expected downtime during this maintenance window. All servers should remain online and operational while our team performs backend upgrades and optimizations.
What we’re improving:
• Connecting Playzor with larger-scale infrastructure systems
• Strengthening proxy layers for higher traffic handling
• Expanding Kubernetes (K8s) and Kafka infrastructure
• Adding advanced backend worker optimizations
• Improving rate limiting and overall platform stability
• Deploying new CI/CD improvements for faster and safer updates
We have also recently added 9 new servers dedicated to Kubernetes and Kafka management to improve scalability and performance under heavy load.
These upgrades are focused on making Playzor stronger, faster, and capable of handling significantly more pressure without downtime.
If you notice anything unusual during the update window, please contact our team or create a support ticket from the checkout/support page.
— Playzor Infrastructure Team
Affected services